System requirements for Office Timeline

Follow

Overview

Office Timeline is an add-in for Microsoft PowerPoint. In order to successfully install Office Timeline, each machine must meet Microsoft's requirements for add-ins.

Requirements

  • Microsoft Windows Vista, Windows 7 (SP1), Windows 8, or Windows 10 (LTSB, CBB and CB). Office Timeline does not run on Windows 10 S. The add-in is functional on Windows XP and Windows Server but unsupported.  See here for more information.

  • 32-bit versions of Microsoft Office 2007 (SP3), 2010, 2013, or 2016.  Although Office Timeline works with 64-bit versions of Office, we do not formally test or support it on 64-bit.  The vast majority of the Office install base is the 32-bit version of Office.  32-bit is recommended by Microsoft unless you have very specific needs for 64-bit.

  • .NET Framework 4.5.2 or greater.

  • Office Timeline installs the VSTO component if it's not already installed on your computer [Download and Install VSTO]. v10.0.60825 is recommended.

  • .NET Programmability Support for PowerPoint enabled in Microsoft Office. .NET Programmability Support is typically enabled by default on Office installations

  • Starting with Office Timeline version 3.17, users do not need to have Microsoft Project installed in order to import Project data into the PowerPoint add-in.

The user should install with Administrator rights in order to have the most stable installation.

 

Download

You can download the latest build of Office Timeline in two different forms:

Have more questions? Submit a request

Comments